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Database Concepts

	Database
	data organized in a way for easy data entry, access, analysis and summary

	DBMS
	Database management system – stores, retrieves, sorts, analyses, prints information

	Object
	any noun that can be described: people, places, products, events, ideas, etc.

	Attributes
	characteristics common to a group of similar objects: name, size, cost, etc.

	Record
	an instance of an object, or a row in a table

	Field
	value for each attribute of an object, or column in a table

	Field name
	an attribute of an object, or a column heading of a table

	Primary key
	field that uniquely identifies each object; no two objects have the same primary key

	Foreign key
	Table field that is a primary key in a different table

	Relational
	Relates tables by common fields so data is stored compactly without redundancy


Database Objects

	Table
	stores data about objects of a similar type in rows and columns, like a spreadsheet

	Query
	extracts data from tables based on criteria you choose, like a powerful searching tool

	Form
	displays and permits entry of data from tables or queries in a format you choose

	Report
	displays and prints some or all data from tables or queries in a format you choose

	Macro
	automates common database actions to make repetitive tasks easier

	Module
	procedures written in Access Basic programming language to perform complex tasks


Viewing a Database

To start Access, click Start, Programs, Microsoft Access. To quit, click the File menu and Exit. 

Open an existing database (e.g. the sample Northwind.mdb), a template, or a blank database.
Click the tabs for Tables, Queries, Forms, Reports, Macros and Modules to see any existing objects.

Notes: 

Save a copy of the sample database in your folder so the original remains undamaged.

Data entered in a database is saved automatically after each record is entered.

Access 95, 97, 2000 and 2002 (XP) have slightly different features and file formats.

Tables

Viewing a Table

To view a table, select the Tables tab, and double-click any table to look at its contents.

To move to different cells, you can use Tab, arrow keys, home, end, page up/down, or scrollbars.

To select a field, click the field name (column heading).

To find data, select a field, click the binoculars (or press Ctrl-F), type text to find, and click Find.
Rearranging Data

To change the order of columns, click the column header to select, then drag to the left or right.

To change a column width, move to the line between two column headers and drag left or right.
To sort rows of data, select a field and click a sort button (ascending A-Z or descending Z-A).

Editing Data

To edit data in a field, click in the cell, press F2 to edit, and use arrows, delete, backspace, etc.

To replace data, double-click in a cell to select the whole cell, and type the new value.

Useful editing shortcuts include Ctrl-X (cut), Ctrl-C (copy), Ctrl-V (paste), and Ctrl-A (select all).

Adding and Deleting Records

To add a record, click Insert->New Record >* (or go to bottom row). Type values in each column. 

To select a record, click the grey rectangle in the leftmost column, or click Edit, Select Record.

To delete a record, select it and press the Delete key or click the >X button, or click Edit, Delete.

Table Structure 

All records in a table contain the same set of fields.

There must normally be a primary key that gives each record its identity and makes it unique.

Every field must have a data type and properties that depend on that data type.

Field Data Types

	Text
	letters, numbers, symbols, spaces, up to 255 characters; used for most fields

	Memo
	text up to 64000 bytes, not indexed, used for long explanations and comments

	Number
	Can contain +/-, digits, decimal sign; used for calculations except money

	Date/Time
	any format of date and/or time (use dd/mm/yyyy format for 31/12/2003)

	Currency
	Used for money; automatically adds currency sign $ and two decimal places

	AutoNumber
	automatically assigns a number for each new record; often used for primary key

	Yes/No
	logical field (true or false, on or off, present or absent, etc.)

	OLE object
	object created by another application like Excel and imported into Access


Field Properties

	Field size
	Number of characters for a field (e.g. a name might have up to 30 characters)

	Decimal places
	For a number field (e.g. 2 places for currency, 0 places for integers)

	Input mask
	Restricts data entry characters to ensure accuracy, e.g. (0741) 422970

	Default value
	If most records will use the same value for this field

	Validation rules
	Constrains allowed data to ensure accuracy; if not, validation text is shown

	Required
	Ensures that data is entered in the field; if not, an error message is shown

	Indexed
	For fast sorting or avoiding duplicates (primary key is indexed, no duplicates)


Validation Rules

	Expressions
	combination of values, constants, operators and functions

	Values
	any number, text, date, etc. (e.g. 3.14, “Marketing Director”, #2/2/95#)

	Constants
	fixed values like True, False, Null, “” (empty string)

	Comparison operators
	=, <>, >, <, >=, <=, between

	Logical operators
	and, or, not, is, like (e.g. Like “*Manager*” will display all managers)

	Arithmetic operators
	+, -, *, /, etc.

	Date/time functions
	Date() shows today’s date, Now() shows current date and time, etc.

	Math functions
	sin, cos, tan, log, exp, sqr, int, abs, rnd, etc.


Creating a Table

1. Click the Table tab, click New, click Design View, and click OK.

2. Type the field name, press Tab, select the data type, and type a description (optional).

3. Assign properties to each field (e.g. field size, format, input mask, caption, validation rules).

4. Choose a field to be a primary key by right-clicking the field and clicking Primary Key.

5. Save, and type a table name.

6. Go to datasheet view, enter some data, and close.

Relationships

Viewing Relationships

Click View, Relationships. Related table fields are connected with a line.

Primary keys are bold. Foreign keys are not bold, but are joined to a primary key in another table.
Most relationships are one-to-many (1 is the primary key; ( is the foreign key).

Two tables with a many-to-many relationship have a one-to-many relationship with a third table.

Creating a Relationship

Drag from the field in one table to the related field in another table.

Select the three check boxes (Enforce Referential Integrity, Cascade Update, Cascade Delete).
This assures that if you delete a record (e.g. a customer) its related records (e.g. orders) are deleted.

Queries

Viewing Existing Queries

1. Click the Query tab and double-click any query.
2. Click the View button to switch between design view and datasheet view (query results).
Top of window: shows one or more tables used in query, with common fields linked by a line.
Bottom of window: shows selected fields (show is checked), totals, sort order, and query criteria.
	Totals
	For numbers: sum, average, max, min; for any field: group by, count, first, last, where 

	Sort
	Whether to sort by a field in alphabetical order (ascending, descending or none)

	Show
	Whether the field appears in the query results, or is only used to select or sort records

	Criteria
	Similar to validation rules (expressions with values, constants, operators, functions)

	Or
	Allows multiple criteria (e.g. title is “Manager” or “Director” or “CEO”)


Creating a Simple Query

1. Click Query tab, click New, click Design View, and click OK.
2. Click the table you want to query and click Add; click Close.
3. Double-click the fields you want in your query, or use the drop-down menus to select them.
4. Click the View or Run (!) button to see results of query in Datasheet view.
5. Save your query by clicking the Save button and typing a name that describes your query.
Creating a Complex Query

You can use any or all of these options:

1. Create a relational query by using more than one table (click the Show Table (+) button).
2. Use results of one query to be part of a new query (click Queries tab in Show Table dialog).
3. Sort by one or more fields (the query will sort first by the leftmost field).
4. Use “totals” to summarize data (click the Totals (() button).
5. Uncheck “show” to use a field only to select records and not show the field in query results.
6. Add query criteria to one or more fields (e.g. age >50 and gender =“female”).
7. Use “or” lines to use multiple criteria.
Filters

A filter is like a query but is not saved as a separate object, and all fields appear in the result.

You can filter by any selected field, by excluding a field, by filling in a form, or an advanced filter.

Reports

Viewing Data with a Report

1. Click the Report tab and double-click any report.
2. Click the View button or Print Preview to go between design view and report preview (results).
3. In report preview, you can scroll, or click arrows |< < > >| to go to different pages of the report.
Report Areas

	Report Header
	Information at the start of the report only (e.g. title)

	Page Header
	Information at the top of each page (e.g. column headings)

	Other headers
	These are inserted automatically when you group the data

	Detail
	One line per record that appears in the report (the data itself; raw or summarised)

	Page Footer
	Information at the bottom of each page (e.g. page totals, page numbers)

	Report Footer
	Information at the end of the report only (e.g. column totals)


Creating a Report with One Table or Query

Click the Report tab and click New.

Click Auto Report: Tabular, select a table or query, and click OK.

Creating a Report with a Wizard

In wizards, you fill out each page of the form and click Next. On the last page, you click Finish.

1. Select a table or query to be used in the report.

2. Select individual fields by clicking > or all fields by clicking >>.

3. If you make a mistake, you can remove individual fields by selecting them and clicking <.

4. If desired, do the same with another table or query.

5. If desired, choose to group and/or sort the report by fields in one of the tables or queries.

6. Choose a layout, orientation and style for the report.

7. Give the report a title and click Finish.

Tips for Editing a Report in Design View

To change the text of a field in a header, click inside it, make changes and press Enter.

To change the font or size of a field, click once on it and select a different font and size.

To resize a field, click once on it and then drag one of the black square handles.

To move a field, drag it to another place, usually within the same section of the report.

To select multiple fields, drag a rectangle around the fields or click or drag in the left margin.

Format them together (e.g. move, align, resize, space, group) using the Format menu and toolbar.
Make sure header labels line up with detail fields.

To delete a field or label, click once on it and press the Delete key.

To add a field and its label, click View->Field List and drag the field name to the Detail area.

To make a section larger or smaller, drag its bottom border.

To change the grouping order, click View->Sorting and Grouping and select fields from the lists.

To add graphics, click View->Toolbox, click a line, box or text tool, and drag on a header area.

To add a picture, click Insert->Picture, select the picture file (.bmp), and click OK.

To make a chart, click New and click Chart Wizard.

To make mailing labels, click New and choose Label Wizard.

Forms

Viewing and Entering Data with a Form

Click the Form tab and double-click any form.

Click the arrow buttons |< < > >| to go to the first, previous, next or last record.

Click on any of the fields to edit the field values.

Press Tab or Shift-Tab to go to the next or previous field.

To add a new record, click the >* button and type in data for each field.

To delete a record, click the >X button.

To copy data from the previous field, press Ctrl-‘.

Creating a Form with One Table or Query

Click the Form tab and click New.

Click Auto Report: Columnar, select a table or query, and click OK. 

(Columnar forms are most commonly used. Tabular and datasheet forms are like the datasheet.)

Creating a Form with a Wizard

1. Select a table or query to be used in the form.

2. For each field to be entered by the user, select it and click >, or click >> to use all fields.

3. (You may want to exclude counter fields that are automatically generated by Access.)

4. Choose a form layout (columnar, tabular, datasheet, justified) and style.

5. Give the form a title.

Tips for Editing a Form in Design View

Click the View button to switch to Design View.

The parts of the form are similar to a report, but normally forms only have one page.

The field label usually appears to the left of or above each field.

To change the text of a field or label, click it, press F2 if needed, make changes, and press Enter.

To change the font or size of a field or label, click once on it and select a different font and size.

To resize a field or label, click once on it and then drag one of the black square handles.

To move a field or label, drag it to another place within the same section of the form.

To add graphics, click View->Toolbox, click a line, box or text tool, and drag on a header area.

To make a pivot table for flexible arrangement of data, click New and click Pivot Table Wizard.

To create a subform, use fields from two related tables. The subform contains the foreign key.
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